Is minimal required platform Windows 7 only for the 5.3 or later for gnuplot for windows?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Is minimal required platform Windows 7 only for the 5.3 or later for gnuplot for windows?

tmacchant
I saw the below in the ChangeLog in cvs branch source

2017-07-07  Bastian Maerkisch  <[hidden email]>
        <snip>
    * src/syscfg.h:  Minimum required API version is Windows 7 by
    default.  Vista and XP are end-of-service.


For gnuplot 5.2.x, is minimal required platform windows XP?

Tatsuro

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

AW: Is minimal required platform Windows 7 only for the 5.3 or later for gnuplot for windows?

Bastian Märkisch
For 5.2 this hasn't changed in syscfg.h. If the Direct2D windows terminal
backend is included in the build, the executable will only run on Vista SP2
with platform upgrade or later, though.  Moreover there could be
restrictions implied by the libraries and compiler chain used, in particular
Qt.

  Bastian

> -----Ursprüngliche Nachricht-----
> Von: Tatsuro MATSUOKA [mailto:[hidden email]]
> Gesendet: Sonntag, 9. Juli 2017 23:30
> An: [hidden email]; [hidden email]
> Betreff: Is minimal required platform Windows 7 only for the 5.3 or later
for

> gnuplot for windows?
>
> I saw the below in the ChangeLog in cvs branch source
>
> 2017-07-07  Bastian Maerkisch  <[hidden email]>
>         <snip>
>     * src/syscfg.h:  Minimum required API version is Windows 7 by
>     default.  Vista and XP are end-of-service.
>
>
> For gnuplot 5.2.x, is minimal required platform windows XP?
>
> Tatsuro
>
>
----------------------------------------------------------------------------
--
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> gnuplot-beta mailing list
> [hidden email]
> Membership management via:
> https://lists.sourceforge.net/lists/listinfo/gnuplot-beta


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: AW: Is minimal required platform Windows 7 only for the 5.3 or later for gnuplot for windows?

tmacchant
Hello

Thanks for the reply.
I understand the situation.

I really appreciate your successive efforts specially on gnuplot for windows.

Tatsuro



----- Original Message -----

> From: Bastian Märkisch
> To: 'Tatsuro MATSUOKA' ; gnuplot-beta
> Cc:
> Date: 2017/7/10, Mon 16:08
> Subject: AW: Is minimal required platform Windows 7 only for the 5.3 or later for gnuplot for windows?
>
> For 5.2 this hasn't changed in syscfg.h. If the Direct2D windows terminal
> backend is included in the build, the executable will only run on Vista SP2
> with platform upgrade or later, though.  Moreover there could be
> restrictions implied by the libraries and compiler chain used, in particular
> Qt.
>
>   Bastian
>
>>  -----Ursprüngliche Nachricht-----
>>  Von: Tatsuro MATSUOKA [mailto:[hidden email]]
>>  Gesendet: Sonntag, 9. Juli 2017 23:30
>>  An: [hidden email]; [hidden email]
>>  Betreff: Is minimal required platform Windows 7 only for the 5.3 or later
> for
>>  gnuplot for windows?
>>
>>  I saw the below in the ChangeLog in cvs branch source
>>
>>  2017-07-07  Bastian Maerkisch  <[hidden email]>
>>          <snip>
>>      * src/syscfg.h:  Minimum required API version is Windows 7 by
>>      default.  Vista and XP are end-of-service.
>>
>>
>>  For gnuplot 5.2.x, is minimal required platform windows XP?
>>
>>  Tatsuro
>>
>>
> ----------------------------------------------------------------------------
> --
>>  Check out the vibrant tech community on one of the world's most
>>  engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>>  _______________________________________________
>>  gnuplot-beta mailing list
>>  [hidden email]
>>  Membership management via:
>>  https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: AW: Is minimal required platform Windows 7 only for the 5.3 or later for gnuplot for windows?

Allin Cottrell
On Tue, 11 Jul 2017, Tatsuro MATSUOKA wrote:

> Thanks for the reply.
> I understand the situation.
>
> I really appreciate your successive efforts specially on gnuplot
> for windows.

Me too, Bastian has done a very nice job.

But your "support for XP" question is similar to one I asked a while
back about support for mingw ("plain old" minGW as opposed to
MingGW-w64). It may well be time to drop support for old
Windows-related software, but I think this should be made clear in
the ChangeLog and among the "config" files in the source tree. You
cannot compile current gnuplot for Windows using plain old minGW any
more, though the presence of files such as config.mgw suggests
otherwise.

Allin Cottrell

> ----- Original Message -----
>> From: Bastian Märkisch
>> To: 'Tatsuro MATSUOKA' ; gnuplot-beta
>> Cc:
>> Date: 2017/7/10, Mon 16:08
>> Subject: AW: Is minimal required platform Windows 7 only for the 5.3 or later for gnuplot for windows?
>>
>> For 5.2 this hasn't changed in syscfg.h. If the Direct2D windows terminal
>> backend is included in the build, the executable will only run on Vista SP2
>> with platform upgrade or later, though.  Moreover there could be
>> restrictions implied by the libraries and compiler chain used, in particular
>> Qt.
>>
>>   Bastian
>>
>>>  -----Ursprüngliche Nachricht-----
>>>  Von: Tatsuro MATSUOKA [mailto:[hidden email]]
>>>  Gesendet: Sonntag, 9. Juli 2017 23:30
>>>  An: [hidden email]; [hidden email]
>>>  Betreff: Is minimal required platform Windows 7 only for the 5.3 or later
>> for
>>>  gnuplot for windows?
>>>
>>>  I saw the below in the ChangeLog in cvs branch source
>>>
>>>  2017-07-07  Bastian Maerkisch  <[hidden email]>
>>>          <snip>
>>>      * src/syscfg.h:  Minimum required API version is Windows 7 by
>>>      default.  Vista and XP are end-of-service.
>>>
>>>
>>>  For gnuplot 5.2.x, is minimal required platform windows XP?
>>>
>>>  Tatsuro
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: AW: Is minimal required platform Windows 7 only for the 5.3 or later for gnuplot for windows?

tmacchant
>>  Thanks for the reply.

>>  I understand the situation.
>>
>>  I really appreciate your successive efforts specially on gnuplot for
> windows.
>
> Me too, Bastian has done a very nice job.
>
> But your "support for XP" question is similar to one I asked a while
> back about support for mingw ("plain old" minGW as opposed to
> MingGW-w64). It may well be time to drop support for old Windows-related
> software, but I think this should be made clear in the ChangeLog and among the
> "config" files in the source tree. You cannot compile current gnuplot
> for Windows using plain old minGW any more, though the presence of files such as
> config.mgw suggests otherwise.
>
> Allin Cottrell

http://gnuplot.10905.n7.nabble.com/5-2-rc2-tarball-now-available-tp20707p20758.html
Bastian> There's now a revision of the MS-Windows INSTALL section in CVS for 5.2.

Now windows section in "INSTALL" tells that config/mingw/Makefile is for MinGW-w64/MSYS2.

I think that config/mingw/Makefile is also revised in corresponding way.

Tatsuro

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Loading...