New stable CVS branch for preparing first version 5.2 release candidate

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

New stable CVS branch for preparing first version 5.2 release candidate

sfeam
There is now a stable branch for 5.2 separate from the main
(development) branch, which for now remains 5.1

To download a copy of the new stable branch (assumes bash shell)

    mkdir gnuplot52
    cd gnuplot52
    export CVSROOT=:pserver:[hidden email]:/cvsroot/gnuplot
    cvs login    (hit Enter when asked for a password)
    cvs -z3 checkout -r  branch-5-2-stable  gnuplot

Any patches, documentation, etc to be included in the first 5.2 release candidate
should be applied to this new stable branch.

Any new features or fixes to code under development should continue to
be applied to the main cvs development branch.

Right now the stable and development branches have identical content except
for version labels.   They will diverge as new patches are applied to one branch
but not the other branch.

        cheers,

                Ethan


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: New stable CVS branch for preparing first version 5.2 release candidate

tmacchant
I tried  to build stable branch for 5.2 on MinGW64.

I have met following errors at link stage.

g++ -Wl,--enable-auto-import -Wl,--enable-runtime-pseudo-reloc-v2  -Wl,--allow-multiple-definition -L/c/Programs/gplibs64_gcc530/lib -s -L/c/Programs/Qt/5.7.1_mgw64_630/lib -mconsole -L/c/Program\ Files\ \(x86\)/HTML\ Help\ Workshop/lib -L. -o gnuplot.exe eval.co getcolor.co stats.co unset.co breaders.co specfun.co term.co graph3d.co dynarray.co show.co axis.co stdfn.co util.co save.co util3d.co tabulate.co readline.co internal.co jitter.co libcerf.co bitmap.co hidden3d.co plot3d.co color.co contour.co command.co multiplot.co plot.co scanner.co gadgets.co plot2d.co tables.co time.co pm3d.co matrix.co boundary.co fit.co misc.co alloc.co external.co help.co interpol.co datafile.co parse.co standard.co variable.co datablock.co graphics.co mouse.co set.co history.co version.co gpexecute.co wxt_gui.co gp_cairo.co gp_cairo_helpers.co qt_term.co  winmain.co wgnuplib.co wgraph.co wprinter.co wpause.co wgdiplus.co wd2d.co wgplt_res.co -lkernel32 -lgdi32
 -lwinspool -lcomdlg32 -lcomctl32 -ladvapi32 -lshell32 -lmsimg32 -lgdiplus -lshlwapi -ld2d1 -ldwrite -lole32 -lhhctrl\
 -lgd -lgd -lz -L/c/Programs/gplibs64_gcc630/lib -lpng16 -lz -L/c/Programs/gplibs64_gcc630/lib -lfreetype -lz -lpng16 -lz -L/c/Programs/gplibs64_gcc630/lib -lfontconfig -lexpat -lfreetype -lz -lpng16 -lz -lexpat -lfreetype -lz -lpng16 -lz -ljpeg -lQt5Core -lQt5Gui -lQt5Network -lQt5Svg -lQt5Widgets -lQt5PrintSupport -lqtmain -llua -lcaca -liconv -lcerf -lm -L/c/Programs/gplibs64_gcc630/lib   -L/c/Programs/gplibs64_gcc630/lib -L/mingw64/lib   -lwx_mswu_xrc-3.0 -lwx_mswu_webview-3.0 -lwx_mswu_html-3.0 -lwx_mswu_qa-3.0 -lwx_mswu_adv-3.0 -lwx_mswu_core-3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0  -L/c/Programs/gplibs64_gcc630/lib -L/c/Programs/gplibs64_gcc630/lib/../lib -L/c/Programs/gplibs64_gcc630/lib -lpangocairo-1.0 -lpangowin32-1.0 -lgdi32 -lusp10 -lpango-1.0 -lm -lcairo -lz -lgobject-2.0 -lffi -lglib-2.0 -lintl -lws2_32 -lole32 -lwinmm -lshlwapi -lintl -lpixman-1 -lfontconfig -lexpat -lfreetype -lz -lpng16 -lz -lexpat -lfreetype -lz
 -lpng16 -lz
term.co:term.c:(.text+0x1468a): undefined reference to `wxt_close_terminal_window'
term.co:term.c:(.text+0x14c99): undefined reference to `wxt_update_title'
term.co:term.c:(.text+0x14ed3): undefined reference to `wxt_update_size'
term.co:term.c:(.text+0x14f85): undefined reference to `wxt_update_position'
term.co:term.c:(.text+0xecd5): undefined reference to `wxt_text'
<snip>
wpause.co:wpause.c:(.text+0x7e1): undefined reference to `wxt_active_window_opened'
collect2.exe: error: ld returned 1 exit status
make[1]: *** [Makefile:617: gnuplot.exe] Error 1
make[1]: Leaving directory '/d/usr/Tatsu/msys2mingw64_630/gnuplot/gnuplot-5.2-cvs/gnuplot/config/mingw'
make: *** [Makefile:567: console] Error 2

Seems to relate to wx-widgetes.

However on 5.1 cvs,

g++ -Wl,--enable-auto-import -Wl,--enable-runtime-pseudo-reloc-v2  -Wl,--allow-multiple-definition -L/c/Programs/gplibs64_gcc530/lib -s -L/c/Programs/Qt/5.7.1_mgw64_630/lib -mconsole -L/c/Program\ Files\ \(x86\)/HTML\ Help\ Workshop/lib -L. -o gnuplot.exe eval.co getcolor.co stats.co unset.co breaders.co specfun.co term.co graph3d.co dynarray.co show.co axis.co stdfn.co util.co save.co util3d.co tabulate.co readline.co internal.co jitter.co libcerf.co bitmap.co hidden3d.co plot3d.co color.co contour.co command.co multiplot.co plot.co scanner.co gadgets.co plot2d.co tables.co time.co pm3d.co matrix.co boundary.co fit.co misc.co alloc.co external.co help.co interpol.co datafile.co parse.co standard.co variable.co datablock.co graphics.co mouse.co set.co history.co version.co gpexecute.co wxt_gui.co gp_cairo.co gp_cairo_helpers.co qt_term.co  winmain.co wgnuplib.co wgraph.co wprinter.co wpause.co wgdiplus.co wd2d.co wgplt_res.co -lkernel32 -lgdi32
 -lwinspool -lcomdlg32 -lcomctl32 -ladvapi32 -lshell32 -lmsimg32 -lgdiplus -lshlwapi -ld2d1 -ldwrite -lole32 -lhtmlhelp\
 -lgd -lgd -lz -L/c/Programs/gplibs64_gcc630/lib -lpng16 -lz -L/c/Programs/gplibs64_gcc630/lib -lfreetype -lz -lpng16 -lz -L/c/Programs/gplibs64_gcc630/lib -lfontconfig -lexpat -lfreetype -lz -lpng16 -lz -lexpat -lfreetype -lz -lpng16 -lz -ljpeg -lQt5Core -lQt5Gui -lQt5Network -lQt5Svg -lQt5Widgets -lQt5PrintSupport -lqtmain -llua -lcaca -liconv -lcerf -lm -L/c/Programs/gplibs64_gcc630/lib   -L/c/Programs/gplibs64_gcc630/lib -L/mingw64/lib   -lwx_mswu_xrc-3.0 -lwx_mswu_webview-3.0 -lwx_mswu_html-3.0 -lwx_mswu_qa-3.0 -lwx_mswu_adv-3.0 -lwx_mswu_core-3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0  -L/c/Programs/gplibs64_gcc630/lib -L/c/Programs/gplibs64_gcc630/lib/../lib -L/c/Programs/gplibs64_gcc630/lib -lpangocairo-1.0 -lpangowin32-1.0 -lgdi32 -lusp10 -lpango-1.0 -lm -lcairo -lz -lgobject-2.0 -lffi -lglib-2.0 -lintl -lws2_32 -lole32 -lwinmm -lshlwapi -lintl -lpixman-1 -lfontconfig -lexpat -lfreetype -lz -lpng16 -lz -lexpat -lfreetype -lz
 -lpng16 -lz
C:/msys64_gcc630/mingw64/bin/../lib/gcc/x86_64-w64-mingw32/6.3.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping incompatible C:/Program Files (x86)/HTML Help Workshop/lib/htmlhelp.lib when searching for -lhtmlhelp

I cannot find any difference in wx-widgets setting at link stage.

Does anyone help me?

Tatsuro

----- Original Message -----

> From: sfeam
> To: gnuplot-beta
> Cc:
> Date: 2017/5/22, Mon 14:48
> Subject: New stable CVS branch for preparing first version 5.2 release candidate
>
>T here is now a stable branch for 5.2 separate from the main
> (development) branch, which for now remains 5.1
>
> To download a copy of the new stable branch (assumes bash shell)
>
>     mkdir gnuplot52
>     cd gnuplot52
>     export
> CVSROOT=:pserver:[hidden email]:/cvsroot/gnuplot
>     cvs login    (hit Enter when asked for a password)
>     cvs -z3 checkout -r  branch-5-2-stable  gnuplot
>
> Any patches, documentation, etc to be included in the first 5.2 release
> candidate
> should be applied to this new stable branch.
>
> Any new features or fixes to code under development should continue to
> be applied to the main cvs development branch.
>
> Right now the stable and development branches have identical content except
> for version labels.   They will diverge as new patches are applied to one branch
> but not the other branch.
>
>     cheers,
>
>         Ethan
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> gnuplot-beta mailing list
> [hidden email]
> Membership management via:
> https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: AW: New stable CVS branch for preparing first version 5.2 release candidate

tmacchant
Thanks for the reply.

I freshly checked out branch-5-2  source.

This time, undefined reference errors were disappeared.

Perhaps I mishandled on Makefile or local patches.

Sorry for the noise.

>-lhhctrl


This self-generated libhhctrl.dll.a for 64 MinGW link library.
There was no definite reason I used my generated libhhctrl.dll.a but not htmlhelp.lib
in Makefile.

Tatsuro


----- Original Message -----

> From: Bastian Märkisch <[hidden email]>
> To: 'Tatsuro MATSUOKA' <[hidden email]>; [hidden email]
> Cc:
> Date: 2017/5/23, Tue 12:41
> Subject: AW: New stable CVS branch for preparing first version 5.2 release candidate
>
> Works flawlessly here. Looks like your 5.2 build of wxt_gui.cpp got broken.
>
> Did you perhaps mangle your Makefile somehow?  (There's an odd reference
> to -lhhctrl which in a normal Makefile should by -lhtmlhelp)
>
>   Bastian
>
>>  -----Ursprüngliche Nachricht-----
>>  Von: Tatsuro MATSUOKA [mailto:[hidden email]]
>>  Gesendet: Dienstag, 23. Mai 2017 04:58
>>  An: Merritt Ethan <[hidden email]>; gnuplot-
>>  [hidden email]
>>  Betreff: Re: New stable CVS branch for preparing first version 5.2 release
>>  candidate
>>
>>  I tried  to build stable branch for 5.2 on MinGW64.
>>
>>  I have met following errors at link stage.
>>
>>  g++ -Wl,--enable-auto-import -Wl,--enable-runtime-pseudo-reloc-v2
>>  g++ -Wl,--allow-multiple-definition -L/c/Programs/gplibs64_gcc530/lib -s
>>  g++ -L/c/Programs/Qt/5.7.1_mgw64_630/lib -mconsole -L/c/Program\
> Files\
>>  g++ \(x86\)/HTML\ Help\ Workshop/lib -L. -o gnuplot.exe
> eval.co
>>  g++ getcolor.co stats.co unset.co breaders.co specfun.co term.co
>>  g++ graph3d.co dynarray.co show.co axis.co stdfn.co util.co save.co
>>  g++ util3d.co tabulate.co readline.co internal.co jitter.co libcerf.co
>>  g++ bitmap.co hidden3d.co plot3d.co color.co contour.co command.co
>>  g++ multiplot.co plot.co scanner.co gadgets.co plot2d.co tables.co
>>  g++ time.co pm3d.co matrix.co boundary.co fit.co misc.co alloc.co
>>  g++ external.co help.co interpol.co datafile.co parse.co standard.co
>>  g++ variable.co datablock.co graphics.co mouse.co set.co history.co
>>  g++ version.co gpexecute.co wxt_gui.co gp_cairo.co gp_cairo_helpers.co
>>  g++ qt_term.co  winmain.co wgnuplib.co wgraph.co wprinter.co wpause.co
>>  g++ wgdiplus.co wd2d.co wgplt_res.co -lkernel32 -lgdi32
>>   -lwinspool -lcomdlg32 -lcomctl32 -ladvapi32 -lshell32 -lmsimg32 -lgdiplus
> -
>>  lshlwapi -ld2d1 -ldwrite -lole32 -lhhctrl\
>>   -lgd -lgd -lz -L/c/Programs/gplibs64_gcc630/lib -lpng16 -lz -
>>  L/c/Programs/gplibs64_gcc630/lib -lfreetype -lz -lpng16 -lz -
>>  L/c/Programs/gplibs64_gcc630/lib -lfontconfig -lexpat -lfreetype -lz
> -lpng16 -lz
>>  -lexpat -lfreetype -lz -lpng16 -lz -ljpeg -lQt5Core -lQt5Gui -lQt5Network
> -
>>  lQt5Svg -lQt5Widgets -lQt5PrintSupport -lqtmain -llua -lcaca -liconv
> -lcerf -lm -
>>  L/c/Programs/gplibs64_gcc630/lib   -L/c/Programs/gplibs64_gcc630/lib -
>>  L/mingw64/lib   -lwx_mswu_xrc-3.0 -lwx_mswu_webview-3.0 -
>>  lwx_mswu_html-3.0 -lwx_mswu_qa-3.0 -lwx_mswu_adv-3.0 -lwx_mswu_core-
>>  3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0  -
>>  L/c/Programs/gplibs64_gcc630/lib -L/c/Programs/gplibs64_gcc630/lib/../lib
> -
>>  L/c/Programs/gplibs64_gcc630/lib -lpangocairo-1.0 -lpangowin32-1.0 -lgdi32
> -
>>  lusp10 -lpango-1.0 -lm -lcairo -lz -lgobject-2.0 -lffi -lglib-2.0 -lintl
> -lws2_32 -
>>  lole32 -lwinmm -lshlwapi -lintl -lpixman-1 -lfontconfig -lexpat -lfreetype
> -lz -
>>  lpng16 -lz -lexpat -lfreetype -lz
>>   -lpng16 -lz
>>  term.co:term.c:(.text+0x1468a): undefined reference to
>>  `wxt_close_terminal_window'
>>  term.co:term.c:(.text+0x14c99): undefined reference to
> `wxt_update_title'
>>  term.co:term.c:(.text+0x14ed3): undefined reference to
> `wxt_update_size'
>>  term.co:term.c:(.text+0x14f85): undefined reference to
> `wxt_update_position'
>>  term.co:term.c:(.text+0xecd5): undefined reference to `wxt_text'
>>  <snip>
>>  wpause.co:wpause.c:(.text+0x7e1): undefined reference to
>>  `wxt_active_window_opened'
>>  collect2.exe: error: ld returned 1 exit status
>>  make[1]: *** [Makefile:617: gnuplot.exe] Error 1
>>  make[1]: Leaving directory
>>  '/d/usr/Tatsu/msys2mingw64_630/gnuplot/gnuplot-5.2-
>>  cvs/gnuplot/config/mingw'
>>  make: *** [Makefile:567: console] Error 2
>>
>>  Seems to relate to wx-widgetes.
>>
>>  However on 5.1 cvs,
>>
>>  g++ -Wl,--enable-auto-import -Wl,--enable-runtime-pseudo-reloc-v2
>>  g++ -Wl,--allow-multiple-definition -L/c/Programs/gplibs64_gcc530/lib -s
>>  g++ -L/c/Programs/Qt/5.7.1_mgw64_630/lib -mconsole -L/c/Program\
> Files\
>>  g++ \(x86\)/HTML\ Help\ Workshop/lib -L. -o gnuplot.exe
> eval.co
>>  g++ getcolor.co stats.co unset.co breaders.co specfun.co term.co
>>  g++ graph3d.co dynarray.co show.co axis.co stdfn.co util.co save.co
>>  g++ util3d.co tabulate.co readline.co internal.co jitter.co libcerf.co
>>  g++ bitmap.co hidden3d.co plot3d.co color.co contour.co command.co
>>  g++ multiplot.co plot.co scanner.co gadgets.co plot2d.co tables.co
>>  g++ time.co pm3d.co matrix.co boundary.co fit.co misc.co alloc.co
>>  g++ external.co help.co interpol.co datafile.co parse.co standard.co
>>  g++ variable.co datablock.co graphics.co mouse.co set.co history.co
>>  g++ version.co gpexecute.co wxt_gui.co gp_cairo.co gp_cairo_helpers.co
>>  g++ qt_term.co  winmain.co wgnuplib.co wgraph.co wprinter.co wpause.co
>>  g++ wgdiplus.co wd2d.co wgplt_res.co -lkernel32 -lgdi32
>>   -lwinspool -lcomdlg32 -lcomctl32 -ladvapi32 -lshell32 -lmsimg32 -lgdiplus
> -
>>  lshlwapi -ld2d1 -ldwrite -lole32 -lhtmlhelp\
>>   -lgd -lgd -lz -L/c/Programs/gplibs64_gcc630/lib -lpng16 -lz -
>>  L/c/Programs/gplibs64_gcc630/lib -lfreetype -lz -lpng16 -lz -
>>  L/c/Programs/gplibs64_gcc630/lib -lfontconfig -lexpat -lfreetype -lz
> -lpng16 -lz
>>  -lexpat -lfreetype -lz -lpng16 -lz -ljpeg -lQt5Core -lQt5Gui -lQt5Network
> -
>>  lQt5Svg -lQt5Widgets -lQt5PrintSupport -lqtmain -llua -lcaca -liconv
> -lcerf -lm -
>>  L/c/Programs/gplibs64_gcc630/lib   -L/c/Programs/gplibs64_gcc630/lib -
>>  L/mingw64/lib   -lwx_mswu_xrc-3.0 -lwx_mswu_webview-3.0 -
>>  lwx_mswu_html-3.0 -lwx_mswu_qa-3.0 -lwx_mswu_adv-3.0 -lwx_mswu_core-
>>  3.0 -lwx_baseu_xml-3.0 -lwx_baseu_net-3.0 -lwx_baseu-3.0  -
>>  L/c/Programs/gplibs64_gcc630/lib -L/c/Programs/gplibs64_gcc630/lib/../lib
> -
>>  L/c/Programs/gplibs64_gcc630/lib -lpangocairo-1.0 -lpangowin32-1.0 -lgdi32
> -
>>  lusp10 -lpango-1.0 -lm -lcairo -lz -lgobject-2.0 -lffi -lglib-2.0 -lintl
> -lws2_32 -
>>  lole32 -lwinmm -lshlwapi -lintl -lpixman-1 -lfontconfig -lexpat -lfreetype
> -lz -
>>  lpng16 -lz -lexpat -lfreetype -lz
>>   -lpng16 -lz
>>  C:/msys64_gcc630/mingw64/bin/../lib/gcc/x86_64-w64-
>>  mingw32/6.3.0/../../../../x86_64-w64-mingw32/bin/ld.exe: skipping
>>  incompatible C:/Program Files (x86)/HTML Help Workshop/lib/htmlhelp.lib
>>  when searching for -lhtmlhelp
>>
>>  I cannot find any difference in wx-widgets setting at link stage.
>>
>>  Does anyone help me?
>>
>>  Tatsuro
>>
>>  ----- Original Message -----
>>  > From: sfeam
>>  > To: gnuplot-beta
>>  > Cc:
>>  > Date: 2017/5/22, Mon 14:48
>>  > Subject: New stable CVS branch for preparing first version 5.2 release
>>  > candidate
>>  >
>>  >T here is now a stable branch for 5.2 separate from the main
>>  > (development) branch, which for now remains 5.1
>>  >
>>  > To download a copy of the new stable branch (assumes bash shell)
>>  >
>>  >     mkdir gnuplot52
>>  >     cd gnuplot52
>>  >     export
>>  > CVSROOT=:pserver:[hidden email]:/cvsroot/gnuplo
>>  > t
>>  >     cvs login    (hit Enter when asked for a password)
>>  >     cvs -z3 checkout -r  branch-5-2-stable  gnuplot
>>  >
>>  > Any patches, documentation, etc to be included in the first 5.2
>>  > release candidate should be applied to this new stable branch.
>>  >
>>  > Any new features or fixes to code under development should continue to
>>  > be applied to the main cvs development branch.
>>  >
>>  > Right now the stable and development branches have identical content
>>  > except for version labels.   They will diverge as new patches are
>>  > applied to one branch but not the other branch.
>>  >
>>  >     cheers,
>>  >
>>  >         Ethan
>>  >
>>  >
>>  > ----------------------------------------------------------------------
>>  > -------- Check out the vibrant tech community on one of the
> world's
>>  > most engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>>  > _______________________________________________
>>  > gnuplot-beta mailing list
>>  > [hidden email]
>>  > Membership management via:
>>  > https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
>>  >
>>
>>
> ----------------------------------------------------------------------------
> --
>>  Check out the vibrant tech community on one of the world's most
> engaging
>>  tech sites, Slashdot.org! http://sdm.link/slashdot
>>  _______________________________________________
>>  gnuplot-beta mailing list
>>  [hidden email]
>>  Membership management via:
>>  https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Loading...