Quantcast

Trouble installer package for gnuplot for mingw( Inno Setup error)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Trouble installer package for gnuplot for mingw( Inno Setup error)

tmacchant
Hello

I have met a trouble at  "make installer"

**************************************************************
(cd ./dist; /c/Program\ Files\ \(x86\)/Inno\ Setup\ 5/iscc gnuplot.iss)
Inno Setup 5 Command-Line Compiler
Copyright (C) 1997-2016 Jordan Russell. All rights reserved.
Portions Copyright (C) 2000-2016 Martijn Laan
Inno Setup Preprocessor
Copyright (C) 2001-2004 Alex Yackimoff. All rights reserved.

Compiler engine version: Inno Setup 5.5.9 (a)

[ISPP] Preprocessing.
[ISPP] Preprocessed.

Error on line 1 in D:\usr\Tatsu\msys2mingw64_530\gnuplot\gnuplotcvs\gnuplot\config\mingw\dist\gnuplot.iss: Text is not inside a section.
Compile aborted.
Makefile:1029: recipe for target 'installer' failed
make: *** [installer] Error 2

**************************************************************

I have cleanly installed windows 10 and use the recent version of Inno Setup 5.
Is this related?


"make zip" goes well without issue.


Any suggestions?

Tatsuro


------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial! http://pubads.g.doubleclick.net/
gampad/clk?id=1444514301&iu=/ca-pub-7940484522588532
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Solved (Re: Trouble installer package for gnuplot for mingw( Inno Setup error))

tmacchant
> From: Tatsuro MATSUOKA

> To: gnuplot-beta; bmaerkisch
> Cc:
> Date: 2016/4/10, Sun 08:51
> Subject: Trouble installer package for gnuplot for mingw( Inno Setup error)
>
> Hello
>
> I have met a trouble at  "make installer"
>
> **************************************************************
> (cd ./dist; /c/Program\ Files\ \(x86\)/Inno\ Setup\
> 5/iscc gnuplot.iss)
> Inno Setup 5 Command-Line Compiler
> Copyright (C) 1997-2016 Jordan Russell. All rights reserved.
> Portions Copyright (C) 2000-2016 Martijn Laan
> Inno Setup Preprocessor
> Copyright (C) 2001-2004 Alex Yackimoff. All rights reserved.
>
> Compiler engine version: Inno Setup 5.5.9 (a)
>
> [ISPP] Preprocessing.
> [ISPP] Preprocessed.
>
> Error on line 1 in
> D:\usr\Tatsu\msys2mingw64_530\gnuplot\gnuplotcvs\gnuplot\config\mingw\dist\gnuplot.iss:
> Text is not inside a section.
> Compile aborted.
> Makefile:1029: recipe for target 'installer' failed
> make: *** [installer] Error 2
>
> **************************************************************
>
> I have cleanly installed windows 10 and use the recent version of Inno Setup 5.
> Is this related?
>
>
> "make zip" goes well without issue.
>
>
> Any suggestions?
>
> Tatsuro
>
I found a trash character at the top of gnuplot.iss.
(I do not know why it exists.)
I deleted it and "make installer" worked without problem.

Tatsuro

------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial! http://pubads.g.doubleclick.net/
gampad/clk?id=1444514301&iu=/ca-pub-7940484522588532
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Solved (Re: Trouble installer package for gnuplot for mingw( Inno Setup error))

sfeam
On Monday, 11 April 2016 10:46:33 AM Tatsuro MATSUOKA wrote:
> >
> I found a trash character at the top of gnuplot.iss.
> (I do not know why it exists.)
> I deleted it and "make installer" worked without problem.

The initial character was the Windows <BOM> marker (Byte Order Mark)
that some Windows programs place at the start of a file to indicate that the
file contains unicode (e.g. UTF-8 or UTF-16) text.  Although the original intent
of the BOM was to make files more portable, in practice it has the opposite
effect  (as you found out)!

   https://en.wikipedia.org/wiki/Byte_order_mark

I have removed it from the cvs copy of win/gnuplot.iss

        Ethan



------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial! http://pubads.g.doubleclick.net/
gampad/clk?id=1444514301&iu=/ca-pub-7940484522588532
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Solved (Re: Trouble installer package for gnuplot for mingw( Inno Setup error))

tmacchant
> From: sfeam
> To: gnuplot-beta Tatsuro MATSUOKA

> Cc: bmaerkisch
> Date: 2016/4/11, Mon 12:22
> Subject: Re: Solved (Re: Trouble installer package for gnuplot for mingw( Inno Setup error))
>
> On Monday, 11 April 2016 10:46:33 AM Tatsuro MATSUOKA wrote:
>>  >
>>  I found a trash character at the top of gnuplot.iss.
>>  (I do not know why it exists.)
>>  I deleted it and "make installer" worked without problem.
>
> The initial character was the Windows <BOM> marker (Byte Order Mark)
> that some Windows programs place at the start of a file to indicate that the
> file contains unicode (e.g. UTF-8 or UTF-16) text.  Although the original intent
> of the BOM was to make files more portable, in practice it has the opposite
> effect  (as you found out)!
>
>   https://en.wikipedia.org/wiki/Byte_order_mark
>
> I have removed it from the cvs copy of win/gnuplot.iss
>
>     Ethan

I have confirmed the fix in the current cvs.
Thanks!

Tatsuro


------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial! http://pubads.g.doubleclick.net/
gampad/clk?id=1444514301&iu=/ca-pub-7940484522588532
_______________________________________________
gnuplot-beta mailing list
[hidden email]
Membership management via: https://lists.sourceforge.net/lists/listinfo/gnuplot-beta
Loading...